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How to resolve Rational DOORS "Error while parsing file ..." errors

Question & Answer


Question

How do you resolve potential data corruption issues in the IBM Rational DOORS database when you see "Error while parsing file ..." errors in the logs?

Cause

If the DOORS database server crashes, or if the server where DOORS is running crashes while the DOORS database server is still running, you may encounter data corruption in your DOORS database.

Some examples:

  • Error while parsing file '/v6data/users/userlist.tc' at line 1:
    expecting DirectoryHeader

    This error indicates that the corrupt file is:

    <DOORS_DATABASE_DIR>/v6data/users/userlist.dtc



  • Error while parsing file '/v6data/module.ix' at line 1: expecting NextIndex
    -R-E- DXL: <config/dbExplorerGlobals.inc:522> An unexpected error has occurred: Unexpected Token
    Backtrace:
    <config/baseWindowCallbacks.inc:64>
    <config/baseWindowCallbacks.inc:107>

    This error indicates that the corrupt file is:
    <DOORS_DATBASE_DIR>/v6data/module.ixc

Answer

If you get errors indicating data corruption in specific files, you may be able to recover from this corruption by leveraging the backup versions of the specified files.

Apply the following steps for the file specified in each Error while parsing file ... error:

NOTE: Please test these steps on a test area before applying on production environment.

  1. Note the file name and location named in the DOORS error that indicates data corruption
  2. Stop the DOORS server
  3. Navigate to the directory specified in the error and search for the file that cannot be parsed
  4. Rename the current version of the problem file to <file_name>.bad
  5. Make a copy of the backup version of the file and rename the copy so that it has the "current" name

    Note:
    The name should be identical to the backup version except that the very last letter in the file extension "b" in the suffix should be changed to "c"

    For example: userlist.dtb becomes userlist.dtc

    When you are done there should be a new "current" version of the file, identical to the existing backup version, and the backup version should be exactly the same as before
  6. Start the DOORS server
  7. Start the DOORS client and see if the problem is resolved

If you get more data corruption errors you will have to repeat this procedure for each corrupt file.

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;9.0;9.1;9.1.0.2;9.2;9.2.0.1;9.2.0.2;9.2.0.3;9.2.0.4;9.2.0.5;9.3;9.3.0.1;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.4;9.4.0.1;9.5;9.5.0.1","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21442348