Question & Answer
Question
How do you purge receipts in IBM Sterling Selling and Fulfillment Suite?
Cause
You are unable to purge when Inspection_pending_flag is set to Y.
Answer
The receipts cannot be purged until the Inspection_pending_flag is set to Y on the receipt. The value of this attribute is not defaulted to Y and it depends on the input to receiveorder API.
This Inspection_pending_flag will be set to Y if:
- The disposition code is not passed.
- You receive with a disposition code which is not a final disposition.
This Inspection_pending_flag will be set to N if:
- You pass a final disposition code.
Passing a disposition code while closing a receipt is required to take the receipts to completion.
Scenario 1:
To proceed on purging the existing closed receipts in the system:
Update YFS_Receipt_Header set Inspection_pending_flag=N where OPEN_RECEIPT_FLAG = N.
Scenario 2:
To prevent any new receipts being closed to be in the same situation:
The receipt should not be received without any disposition code.
Workaround:
Set up a dummy disposition code and pass the same while closing the receipts(receiveOrder API).
Ensure that the dummy disposition Code is configured as type FinalDisposition.
This would inturn ensure that IS_INSPECTION_PENDING flag is passed as N and the receipts get purged as expected.
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Document Information
Modified date:
16 June 2018
UID
swg21597183