Question & Answer
Question
How to perform a UDL test to check the SQL Server Connectivity.
Note: The same UDL test can be used to test connectivity to an external data source when it is being used as the source data within an iBase import specification.
Cause
Unable to open an iBase SQL Server Database
Answer
To perform a UDL Test:
On the Desktop of a machine where the problem occurs, right click, New => Text Document.
Rename it to iBase Test.UDL
Double-click to open your .udl file. Configure using the Provider tab of the user interface.
Provider tab
Choose Microsoft OLE DB Provider for SQL Server
Connection tab
1. Enter the details of your SQL Server (including instance name).
2. Use the same login information that iBase uses.
3. Choose your database from the list.
Test the Connection – it should succeed.
Click on OK and OK again to exit the program.
On the Desktop of a machine where the problem occurs, right click, New => Text Document.
Rename it to iBase Test.UDL
Ensure that it is a "Microsoft Data Link" file type, which has an icon as show in the image above.
If it's showing as a "Text Document", remove the .txt suffix.
To remove the .txt suffix, ensure that File Name Extensions are displayed in File Explorer.
Double-click to open your .udl file. Configure using the Provider tab of the user interface.
Provider tab
Choose Microsoft OLE DB Provider for SQL Server
Connection tab
1. Enter the details of your SQL Server (including instance name).
2. Use the same login information that iBase uses.
3. Choose your database from the list.
Test the Connection – it should succeed.
Click on OK and OK again to exit the program.
Note: For an Oracle connection:
After installing an Oracle client and several reboots, this will present additional providers listed in the Data Link Properties dialog. Selecting ‘Oracle Provider for OLE DB' and giving the connection alias established in the local tnsnames.ora file, works for both a UDL file and in iBase.
[{"Type":"SW","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"ARM Category":[{"code":"a8m50000000Ci92AAC","label":"i2 iBase and i2 Analyst's WorkStation->Import\/Export"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]
Historical Number
TS002929633
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Document Information
Modified date:
11 May 2021
UID
swg21619402