Troubleshooting
Problem
Cognos Analytics is not working as expected. The Custom Filter dialog in the new reporting UI in Cognos 11 has changed, and certain functionality users may have leveraged to define advanced filter conditions in Cognos 10 is no longer available. For example, users cannot leverage Starts With, Ends With, Contains, or Matches SQL Pattern.
Cause
Cognos Analytics has a redesigned UI which was streamlined to attempt to simplify the filter process.
Resolving The Problem
The current simplified version of filter dialog does not support advanced filter features. This is a product limitation we would like to address in a future release. For customers who need to use advanced filter features, please use the following workaround to enable the legacy filter dialog. This is a temporary solution until the new enhanced filter dialog is completed.
Steps to enable the legacy filter dialog:
1) On each server, Locate DefaultSettings.xml under webcontent/bi/pat (note, this is not in the webcontent/pat)
2) Change <setting name="UseOldCustomFilterDialog" defaultValue="false" dataType="boolean" propType="debug" label="Use Old Filter Dialog"/>
to
<setting name="UseOldCustomFilterDialog" defaultValue="true" dataType="boolean" propType="debug" label="Use Old Filter Dialog"/>
4) Re-Start the server.
This will return custom filter to C10 design.
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Document Information
Modified date:
26 September 2018
UID
swg22016757