Question & Answer
Question
How do you enable IBM Rational DOORS client-side logging?
Cause
Rational DOORS Support might request that you enable client-side logging to further debug a problem that occurs in Rational DOORS client; this diagnostic procedure is not documented.
Answer
There are two options to enable DOORS client-side logs:
1. You run a DXL command from your DOORS client to enable client-side logging.
Run the following DXL from Rational DOORS client before you start the operation you need to debug:
string logfileLocation = "c:\\temp\\doorsclientlog.txt"
int logLevel = 6
startLogging_(logfileLocation, logLevel)
2. You can add logging for the DOORS client during startup using the following parameter.
doors.exe -msgLogFile "C:\temp\doorsclientlog.txt" -msgLogLevel 6
Note: There is no sensitive information in the log, only file transactions.
After the operation that requires logging is complete, you need to
- Exit the DOORS client
- Compress the log files (such as: .zip file) and send it to IBM Support.
DOORS client-side logging is automatically disabled when you exit the DOORS client.
You can also disable logging by running the following DXL command from Tools > Edit DXL:
stopLogging_()For more information, see Enabling a transaction log in the IBM Rational DOORS client in the IBM Knowledge Center.
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Document Information
Modified date:
01 May 2020
UID
swg21429583