IBM Support

HMC V9R2M950 returns "Proxy Error" during navigation of the Enhanced UI

Troubleshooting


Problem

Navigating the HMC Enhanced UI can result in the page displaying the following messages:
Proxy Error

The proxy server received an invalid response from an upstream server. 
The proxy server could not handle the request GET /ui/sfp/.            
                                                         
Reason: Error reading from remote server      
image 7732                        

Symptom

The HMC Enhanced UI becomes unusable soon after a reboot of the HMC with only a few hours or a few days of run time.  Managing virtual i/o servers, partitions and managed systems becomes impossible once the "Proxy Error" is returned.
Typically, the symptom is reported after upgrading an existing HMC to V9R2M950 and the problems begin. However, any scratch install or new install of V9R2M950 can exhibit the same problems.
Other related SRCs can also report on the HMC:
E212E116: exceeded the number of threads
E332FFFF: Java dump posted
E23D040C: [*PCERROR-D] core dump of a process
E23D0503: core dump of a process
E3D46FFF: call home exception

Cause

The core JVM is running out of memory due to the enablement of the Simplified Remote Restart capability for some or all partitions.  The more managed systems being managed and the more partitions with the feature enabled the faster the JVM runs out of memory.

Environment

7063-CR1
Virtual Appliance for x86
Virtual Appliance for ppc
HMC Version 9 Release 2 M950

Diagnosing The Problem

Anytime the "Proxy Error" is returned at V9R2M950 after some uptime following a reboot of the HMC confirms this problem as the issue.

Resolving The Problem

The workaround is to reboot the HMC whenever the "Proxy Error" is received, providing relief for some time until the JVM runs out of memory again.  Disabling Simplified Remote Restart across the entire customer environment is another workaround to avoid the reboots.
Reinstalling the HMC will not resolve the cause of the problem.
The official fix is available on fix central for this issue in the February 2021 PTF.  If the interim patches were installed on the HMC before the February PTF was available, both patches must be removed prior to installing the February PTF.
PTF MH01881 - HMC V9 R2 950.4 vHMC for x86_64 hypervisors (5765-HMW)
PTF MH01882 - HMC V9 R2 950.4  - for 7063 Machine Types or vHMC for PowerVM (5765-HMB)
Fixed proxy server errors that prevented  using the GUI requiring a reboot. Call home SRCs of E212E116, E332FFFF, E23D040C and E23D0503 may also be reported. The detailed error message presented during navigation is: 
Proxy Error
 
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /ui/.
 
Reason: Error reading from remote server

Document Location

Worldwide

[{"Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SGGSNP","label":"Hardware Management Console V9"},"ARM Category":[{"code":"a8m0z0000001jEzAAI","label":"HMC Enhanced UI"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.2.0"},{"Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SGGSNP","label":"Hardware Management Console V9"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
22 September 2021

UID

ibm16398722