IBM Support

Help links in Maximo Manage 8.3 do not display documentation

Troubleshooting


Problem

In the Maximo Manage 8.3.x application in Maximo Application Suite 8.7, when you click the help icon on the toolbar from within an application, a web page displays a message that no content is found. No application help is displayed.

Symptom

When you click the application help icon from within a Maximo Manage 8.3.x application, such as Work Order Tracking, a web page displays the following message:
We're sorry!
Content not found

Cause

The URL that links to Maximo Manage application help topics is constructed by using properties that are defined in the mxe.help system property, values that are specified for the product taxonomy in the help_products.xml file, and directory paths that are specified in the presentation XML file for the application. 

Resolving The Problem

There are two solutions for this issue. 
  • You can use a workaround.
  • You can update your Maximo Manage help configuration to fix the problem.
Workaround
If you do not want to reconfigure Maximo Manage help, you can complete the following steps to access Maximo help topics:
1.  When the content-not-found page is displayed, select the Show full table of contents check box, as shown in the following image:
        content not found with checkbox highlighted
      A full table of contents for the documentation is displayed.
2.  In the Documentation search bar, enter search terms for the help topics that you want to view, or browse the table of contents to find the help topics that you need.
Reconfiguring Maximo Manage help to fix the problem
To reconfigure help, complete the following task:
Configuring the help_products.xml file in Maximo Manage
1.  Create a customization archive with a directory structure that matches the /SMP/maximo structure that is used for Maximo Manage. Ensure that you include the following directories so that you can add an updated help_products.xml file to the features directory.
 ../applications/maximo/properties/product/features/
2.  Copy the help_products.xml file from your instance of Maximo Manage to the features directory in your customization archive.
 ../applications/maximo/properties/product/features/help_products.xml
3.  Make the following changes and update the following product packages in the help_products.xml file that you copied:
From:
 
   <product>
        <packagename>com.ibm.mam.doc</packagename>
        <name>IBM Maximo Civil Infrastructure</name>
        <taxonomy>SS3KWD</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
    <product>
        <packagename>com.ibm.mbs.doc</packagename>
        <name>IBM Maximo Civil Infrastructure</name>
        <taxonomy>SS3KWD</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
    <product>
        <packagename>com.ibm.support.mbs.doc</packagename>
        <name>IBM Maximo Civil Infrastructure</name>
        <taxonomy>SS3KWD</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
    <product>
        <packagename>com.ibm.mif.doc</packagename>
        <name>IBM Maximo Civil Infrastructure</name>
        <taxonomy>SS3KWD</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
To:
    <product>
        <packagename>com.ibm.mam.doc</packagename>
        <name>IBM Maximo Manage</name>
        <taxonomy>SSLPL8</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
    <product>
        <packagename>com.ibm.mbs.doc</packagename>
        <name>IBM Maximo Manage</name>
        <taxonomy>SSLPL8</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
    <product>
        <packagename>com.ibm.support.mbs.doc</packagename>
        <name>IBM Maximo Manage</name>
        <taxonomy>SSLPL8</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
    <product>
        <packagename>com.ibm.mif.doc</packagename>
        <name>IBM Maximo Manage</name>
        <taxonomy>SSLPL8</taxonomy>
        <appendversion>Y</appendversion>
        <feature>N</feature>
    </product>
4.    Save the file.

5.    Create an archive of the directories that contain your customizations and copy the archive to a location that is accessible to Maximo Application Suite.
6.    Log in to Maximo Application Suite as a system administrator.

7.    From Suite administration, select Workspaces from the side navigation menu and then select the Manage tile.
8.    On the Manage workspace details page, click Actions and select Update configuration.

9.    In the Customization row on the Update Manage configuration window, click the Edit icon.

10.    In the Customization section of the configuration window, specify the URL for the customization archive file. The following URL protocols are supported: HTTP, HTTPS, FTP, and FTPS.

11.    Optional: If you applied password security to the file, in the Credentials field, specify the user ID and password in the following format:

    user=<your user name>
    password=<your password>

12.    After you complete all configurations, select one of the following options:
      •    If you are configuring a new deployment, click Activate.
      •    If you are updating a deployment, click Apply changes.

Document Location

Worldwide

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Document Information

Modified date:
31 August 2022

UID

ibm16616585