IBM Support

Help links for industry solution applications in Maximo Application Suite 8.8 do not display documentation

Troubleshooting


Problem

In the industry solution applications in Maximo Application Suite 8.8, when you click the application help icon on the toolbar from within an application, a web page displays a message that no content is found. No application help is displayed. 

Symptom

When you click the application help icon from within a Maximo Application Suite application, such as the Assets application, a web page displays the following message:
We're sorry!
Content not found

Cause

The URL that links to application help topics is constructed by using properties that are defined in the mxe.help system properties, values that are specified for the product taxonomy in the help_products.xml file, and directory paths that are specified in the presentation XML file for the application. There are 2 issues that can prevent industry solution application help from displaying properly in Maximo Application Suite 8.8.
  • The value that is specified for the mxe.help.path system property is /support/knowledgecenter/. The value should be /docs/.
  • The values that are displayed for the application taxonomy in the help_products.xml file might not be accurate, as shown in the following example. In the example a taxonomy for Maximo for Civil Infrastructure is provided for the com.ibm.mam.doc package instead of a Maximo Manage taxonomy: 
       <product>
           <packagename>com.ibm.mam.doc</packagename>
           <name>IBM Maximo Civil Infrastructure</name>
           <taxonomy>SS3KWD</taxonomy>
           <appendversion>Y</appendversion>
           <feature>N</feature>
       </product>

Resolving The Problem

There are two solutions for this issue. 
  • You can use a workaround.
  • You can update your Maximo Application Suite help configuration to fix the problem. This document provides instructions for configuring  application help and an updated help_products.xml file that you can add to your deployment.
Workaround
If you do not want to reconfigure help, you can complete the following steps to access application help topics:
1.  When the content-not-found page is displayed, select the Show full table of contents check box, as shown in the following image:
        content not found with checkbox highlighted
      A full table of contents for the documentation is displayed.
2.  In the Documentation search bar, enter search terms for the help topics that you want to view, or browse the table of contents to find the help topics that you need.
Reconfiguring help to fix the problem
To reconfigure help, complete the following two tasks:
  • Update the value that is specified in the mxe.help.path system property.
  • Configure the help_products.xml file to specify the appropriate taxonomy and version parameters. 
Updating the mxe.help.path system property
1.  Log in to the application as an administrator.
2.  Go to System Configuration > Platform Configuration > System Properties.
3. Search for the mxe.help system properties.
4. For the mxe.help.path property, specify /docs/, as shown in the following example:
     image-20220803134822-1
5.  Save your changes.
6.  In the Common Actions menu, click Live Refresh.
Configuring the help_products.xml file
1.  Create a directory for your customizations with a directory structure that matches the /opt/IBM/SMP/maximo structure that is used for your application. Ensure that you include the following directories so that you can add an updated help_products.xml file to the features directory.
 ../applications/maximo/properties/product/features/
2.  Download the attached help_products.xml file and copy the help_products.xml file to the features directory in your customization directory.
3.  Create an archive of the directories that contain your customizations and copy the archive to a location that is accessible to Maximo Application Suite.
4.  Log in to Maximo Application Suite as a system administrator.

5.  From Suite administration, select Workspaces from the side navigation menu and then select the tile for your application.

6.  On the Manage workspace details page, click Actions and select Update configuration.

7.  In the Customization row on the Update configuration window, click the Edit icon.

8. In the Customization section of the configuration window, specify the URL for the customization archive file. The following URL protocols are supported: HTTP, HTTPS, FTP, and FTPS.

9. Optional: If you applied password security to the file, in the Credentials field, specify the user ID and password in the following format:
        user=<your user name>
        password=<your password>

10. After you complete all configurations, select one of the following options:
  •           If you are configuring a new deployment, click Activate.
  •           If you are updating a deployment, click Apply changes.
For more information about creating customization archives, see Customizing the application.

Document Location

Worldwide

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Document Information

Modified date:
25 August 2022

UID

ibm16609880