Troubleshooting
Problem
When running the install of the Guardium STAP on IBM i you can not complete the installation and receive the message: Please make sure call SYSPROC.SYSAUDIT_Status(1,0,null) return server status and try again
Symptom
An example of the full sequence you see on the IBM i command line is below:
#guard-itap-9.0.0_r57263_v90_1-aix-5.3-aix-powerpc.sh <collector ip>
21940+0 records in
43880+0 records out
Checking whether Audit Server has been stopped. (This call may take a minute. Please wait.)
Please make sure call SYSPROC.SYSAUDIT_Status(1,0,null) return server
status and try again
Cause
The configuration file qsys2/sysaudit exists on the system but is empty. The file needs to have at least one entry, or not exist at all for the install to proceed.
Environment
Guardium STAP for IBM i
Diagnosing The Problem
To check the qsys2/sysaudit from the IBM i command line:
STRSQL
select * from qsys2/sysaudit
If this file is empty then proceed with the solution.
Resolving The Problem
1. Drop the qsys2/sysaudit file.
STRSQL
drop table qsys2/sysaudit
2. Retry the STAP installation
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21682442