Troubleshooting
Problem
Guardium Schedule tasks like Import and Archive will not fire at the scheduled time if Central Manager Portal User Sync is running
Symptom
This schedule conflict described below is specific to Central Manager Aggregator only.
For example :
In Guardium Monitor -> Aggregation/Archive Log, we see Backup (Portal User Sync) schedule runs every 30 minutes.
2014-05-20 04:06:47.0 -> 2014-05-20 03:36:41.0
Where you have a CM Backup configured for Central Manager Redundancy you may see the following
This backup comes from Portal User Sync which is defined to run every 30 minutes starting at 00:00. Based on aggregation/archive log, we know Portal User Sync (CM Sync) takes around 5-6 minutes to complete in this example
Data Import starts at 4am and realises that CM Sync is still running, and so the Import will abort, giving this error.
In the agg_progress.log file (available via fileserver you can see errors as below )
* 05/20 04:00:01 --- Import cannot start (guard_agg|turbine_backup.sh|restore_from_file.pl already running)
* 05/20 20:00:46 --- Merge cannot start - aggregation still active
Cause
Portal User Sync causes the Import to fail due to a schedule conflict.
In this example the Import schedule time was at 4am, while the CM Portal User Sync's schedule is to run every 30 minutes.
Diagnosing The Problem
Resolving The Problem
You can do a quick test that is to set the Import schedule for 2 minutes time - specifically schedule it just after you know the Portal User Sync has just finished.
Import should now work with no schedule conflict
Recommendations:
Set the scheduled Portal User Sync and Import to not conflict with each other
- For example
- - Set Portal User Sync to happen only every 1 hour (previously every 30 minutes).
- Since the CM Sync takes about 5 minutes, set Import to 4:30am every day to avoid conflict (previously 4am) .
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Document Information
Modified date:
16 June 2018
UID
swg21674056