IBM Support

Guardium S-TAP installation is failing on a Windows server where S-TAP was previously uninstalled

Troubleshooting


Problem

Windows S-TAP installation is not completing on a server where S-TAP was previously uninstalled.

Cause

It is important to reboot Windows after uninstalling an S-TAP. If Windows is not rebooted, and then installation of a new S-TAP is attempted, the remaining drivers from old install prevent the new installation from completing. If this occurs, the S-TAP should be manually uninstalled with the below process so that a new S-TAP can be installed as a fresh install.

The manual uninstall process should only be used when the normal uninstall process does not work. For example in the scenario outlined above.

Resolving The Problem

To manually uninstall Windows S-TAP:
1. Stop any running Guardium services from the Windows Services screen
2. Prepare the Windows S-TAP installer (by running “cd /<Guardium install dir>”) and run “setup.exe /s /zREMOVE-ALL”
3. Check for ‘IBM Security Guardium Windows S-TAP' in Uninstall or change a program on the Control Panel. If it exists, uninstall it.
4. Check that an S-TAP install directory does not exist (e.g. C:\Program Files\Guardium\GUARDIUM_STAP). If it does exist, delete it.
5. Check that these files do not exist. Delete them if they do exist:

    i) C:\guardiumStaplog.txt
    ii) C:\Windows\SysWOW64\guard_tap.ini
6. Check that there are no drivers installed with the driverquery Proxy and Date commands, and remove any drivers found:

7. Reboot the system

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.0;10.0.1;10.1;10.1.2;9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21999564