IBM Support

Guardium Policy not installed - Err:Duplicate entry '2147483647' for key 'PRIMARY'

Troubleshooting


Problem

Getting following error on IBM Security Guardium when pushing policy from Central Manager (CM) to Managed Units (MU). Error on CM while pushing policy to MU: Err:Duplicate entry '2147483647' for key 'PRIMARY' - Policy not installed

Symptom

In a large environment where there is a requirement to schedule policy install on MU, the CM will keep on re-installing the policy on units. This causes AUTO_INCREMENT value in an internal policy related table to reach its maximum (2147483647) and hence produces the below error on CM

Cause

AUTO_INCREMENT value in internal table reaches its maximum

Environment

v10.1.3

Resolving The Problem

This issue is going to be fixed in 10.1.5 and tentative date of it's release is Q2 2018.

For temporary resolution, please open a case and request patch p1139 from support

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Appliances","Platform":[{"code":"PF016","label":"Linux"}],"Version":"10.1.3","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg22011389