IBM Support

Guardium datasource connection to MSSQL Server. Could not connect within timeout period of: 60 seconds

Troubleshooting


Problem

The steps to configure an MSSQL datasource connection with Windows authentication were followed as per: http://www-01.ibm.com/support/docview.wss?uid=swg21672056 When pressing "test connection" on the datasource a pop up error message appears, for example: Could not connect to: 'MS SQL SERVER-jtds :1433' for user: 'USER' within timeout period of: 60 seconds. TimeoutException: null

Cause

Open source JDBC drivers: jtds-1.2.8.jar (MS SQL Server), and jtds-1.2.2.jar (MS SQL Server) have a defect that can cause this error.

Diagnosing The Problem

When pressing "test connection" on the datasource definition you get a pop up error for example:

Could not connect to: 'MS SQL SERVER-jtds <server ip>:1433' for user: 'USER' within timeout period of: 60 seconds. TimeoutException: null

Resolving The Problem

Guardium support can provide an updated driver with fix that can be uploaded to overwrite the existing jtds driver. Currently the driver is not available publicly.

  1. Contact Guardium support and request the fixed jtds driver for this problem.
  2. Use the steps to resolve the problem in the technote below, but use the .jar file received in point 1.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Appliances","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.0;9.0;9.1;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21967739