IBM Support

Guardium backup CM does not appear when designating backup CM

Troubleshooting


Problem

When using the "Designate Backup CM" function in the Central Manager GUI you either get an error message "No candidate for Backup CM found", or the backup CM you want to use does not appear in the list.

Symptom

When you click the "Designate Backup CM" function in the Central Manager GUI (Admin Console > Central Management > Central Management > "Designate Backup CM") you do not see your backup CM as an option, or you get the following error message:


Cause

All patches installed after the latest GPU in the primary CM needs to be the same on the backup CM.

The order of the installed patches after the latest GPU does not matter, as long as the list is the same on both CMs.

Diagnosing The Problem

To check this you need to do the following:

    1. Take a patch install must gather using the following CLI command for both the primary and backup CMs
        support must_gather patch_install_issues
    2. Download the must gather files and unzip them
    3. Compare the TIMESTAMP column in the INSTALLED_PATCH.csv log files. This is the variable checked when the "Designate Backup CM" function runs
    4. If the list of patches with TIMESTAMP greater than the latest GPU patch is not exactly the same in the backup CM and the primary CM, this can cause the above issue.

    Note: The order that the list of patches appears in the log file is not necessarily the same as the order they were installed.
      For example, as in the below screenshot of INSTALLED_PATCH.csv, if health check patch 9997 is installed before each GPU, a new entry is not made in this log file, but the timestamp is updated.

Resolving The Problem

To resolve this there are two options:


    1. Reinstall all patches on the backup CM from the latest GPU upwards in exactly the same order as on the Primary CM. This order is the one in the TIMESTAMP column in the INSTALLED_PATCH.csv file from the Primary CM.

    2. If you are not able to install all patches again on the backup CM appliance or have installed older patches, log a PMR including patch install must gathers from both the primary and backup CMs. Support will be able to manually change the TIMESTAMP variable on the backup CM.


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Document Information

Modified date:
16 June 2018

UID

swg21986019