IBM Support

Guardium audit process fails with error: Failed to create a merge Database for this Audit Task.

Troubleshooting


Problem

When running a scheduled or ad-hoc audit process you see an error in the audit process log immediately after running the process. There are several enteries with the errors: Failed to create a merge Database for this Audit Task. Failed to select one and only one row.

Symptom

Full error text in the GUI->Guardium Monitor->Audit Process Log

Error Generating merge period for Audit Process: Failed to create a merge Database for This Audit Task.com.guardium.presentation.util.SQLCallQuery.processMergePeriod(SQLCallQuery.java:1556)

Failed to select one and only one row.com.guardium.datamodel.results.ReportResultHeaderPeer.retrieveByPK(ReportResultHeaderPeer.java:80)

Cause

Internal aggregator tables are not available for creating the temporary database to run the audit process. One possible cause is that the audit process is conflicting with an aggregation process.

Environment

Audit process run on aggregator

Diagnosing The Problem

Check in the launch_agg.log and agg_progress.log files, available in fileserver.

Check at the time when you receive the audit process error to see if there any other processes running.

In this example, the audit process error was coming at 5am. In the launch_agg.log, extract below, at 5am it is clear that an archive process is running at that time. This is a conflict that can cause the error above.


======================================================
2014-10-07 04:00:02 : AGGREAGATION STARTED (archive)
======================================================
 * 10/07 04:00:02 --- Get Days - Started
 * 10/07 04:00:02 --- Get Days - Done (1 days)

==============>  archive Day #735877
 * 10/07 04:00:02 --- dump2file - Started
 * 10/07 06:07:40 --- dump2file - Done (agg, tar)

Resolving The Problem

If you discover a conflict with any aggregation process by the method above, reschedule your audit process to run at a time when all aggregation processes are completed.

If you find there is no conflict, or changing schedule does not resolve the problem, please contact IBM support. Please provide the following information:

  • File created when running CLI: support must_gather agg_issues
  • File created when running CLI: support must_gather scheduler_issues
  • File created when running CLI: support must_gather audit_issues
  • CSV export of GUI->Guardium Monitor->Audit Process Log

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Central Manager and Aggregator","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.2;9.0;9.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21686791