Troubleshooting
Problem
Archive fails in IBM Infosphere Guardium and following scheduled Jobs Exceptions Alerts are received : Subject: (machine-name) (INFO) Alert Scheduled Jobs Exceptions Alert Scheduled Jobs Exceptions - Scheduled Job Exceptions > 0 : current value 1 , threshold 0 , query period 4/13/11 1:15 AM - 4/13/11 2:15 AM Alert Classification: Category: Severity: INFO Alert Details Exception Timestamp Exception Description Count of Exceptions 2011-04-13 02:04:26.0 dataArchiveJob trigger: dataIOJobGroup. dataArchiveJob DataAggJob.execute(): I/O Error during data archive: 1 -- Subject: (machine-name) (INFO) Alert Scheduled Jobs Exceptions Alert Scheduled Jobs Exceptions - Scheduled Job Exceptions > 0 : current value 1 , threshold 0 , query period 4/13/11 2:16 AM - 4/13/11 3:16 AM Alert Classification: Category: Severity: INFO Alert Details Exception Timestamp Exception Description Count of Exceptions 2011-04-13 03:13:08.0 dataArchiveJob trigger: dataIOJobGroup. dataArchiveJob DataAggJob.execute(): I/O Error during data archive: 1 ---
Symptom
Following type of exception alerts are received :
Alert Details
Exception Timestamp Exception Description Count of Exceptions
2011-04-13 02:04:26.0 dataArchiveJob trigger: dataIOJobGroup.
dataArchiveJob
DataAggJob.execute(): I/O Error during data archive: 1
Cause
1. When data beyond retention period has not been purged.
2. When a job prior to this scheduled job is running for a long time and has not completed.
Diagnosing The Problem
from cli run and review the outputs of the generated logs
1. support must_gather agg_issues
2. support show db-top-tables all
Resolving The Problem
1. Purge data beyond retention period and re-run the Import/Merge.
2. Check the aggregation/archive log to see if some other job is running for a long time and conflicting with this scheduled job. If there is any such job then schedule of jobs has to be adjusted so that each job has enough time to complete.
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Document Information
Modified date:
16 June 2018
UID
swg21620408