Troubleshooting
Problem
Merge process fails with message "n table(s) were not merged" in the Aggregation/Archive Log (GUI->Guardium Monitor->Aggregation/Archive Log)
Symptom
The Aggregation/Archive Log will have a "Failed" merge process record. An example of this error is below:
Cause
The merge of collector table(s) has failed because the schema on the source appliance did not match the schema definition stored in the Aggregator.
One possible cause of this issue is different patch levels different between the Collector and Aggregator appliances.
Diagnosing The Problem
In the Aggregation/Archive log, a message associated with the merge process will be displayed. This will indicate how many tables have failed this merge process.
Resolving The Problem
1. Check patch levels are identical between the Aggregator and the Collector(s). Install any required patches. This includes Sniffer patches for v9 appliances, (Eg. p40XX).
2. If problem exists after Aggregator and Collector patch levels are the same, Guardium support will need to investigate. Go through the below steps to collect the required information for support.
- i) Use the "fileserver" command from CLI.
ii) Navigate to the "agg_workspace" directory.
iii) Send a screenshot of the entire contents of the directory. There will be files with .diff and .bad.sql type with format:
<table name>__N__<date>__<appliance hostname>.<filetype>
iv) Send the ".diff" and ".bad.sql" file for each unique table name and hostname combination. There is no need to send files with same table name and hostname but different date. For example, from the files below you should send 1 and 3.
- 1. GDM_SESSION__N__20140724__guard1.diff
2. GDM_SESSION__N__20140725__guard1.diff
3. GDM_CONSTRUCT__N__20140725__guard1.diff
Related Information
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21686711