IBM Support

Group search returns short names

Troubleshooting


Problem

Attempts to search for groups in IBM Websphere Application Server (WAS) 'Security role/user mapping' interface results in only short names of the groups being displayed, rather than full distinguished names.

Cause

Attributes groupsDisplayName and groupSecurityName are set to 'cn'.

Environment

WAS server using federated repositories as authentication method.

Resolving The Problem

Procedure:

  1. Navigate to the WAS Console in the web browser.

  2. Navigate to Security > Global Security > Federated repositories and click Configure.

  3. Click User repository attribute mapping.

  4. Change the value of groupsDisplayName and groupSecurityName to 'uniqueName'.

  5. Accept and save to master configuration.

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Administrative Console (all non-scripting)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.5.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21972527