IBM Support

Getting error "CCL-PLG-0001 Failed to load the pluggable shared library. libRSRequest.so: wrong ELF class: ELFCLASS64"

Troubleshooting


Problem

Getting following Error while trying to run reports : CCL-SRV-0501 The BIBusTKServer process caught an unexpected exception. CCL-PLG-0001 Failed to load the pluggable shared library. libRSRequest.so: wrong ELF class: ELFCLASS64

Symptom

Observed the following error in <Install Location>/logs/cognosserver.log

CCL-SRV-0501 The BIBusTKServer process caught an unexpected exception. <Messages><Message Name="CCLMessage" File="cclbitmsgs" Severity="Error" Nesting="0" ><MessageText>CCL-SRV-0501 The BIBusTKServer process caught an unexpected exception.</MessageText></Message><Message Name="CCLMessageString" File="" Severity="Error" Nesting="0" ><MessageText>CCLRuntimeError</MessageText></Message><Message Name="CCLMessageString" File="" Severity="Error" Nesting="0" ><MessageText>CCL-PLG-0001 Failed to load the pluggable shared library. libRSRequest.so: wrong ELF class: ELFCLASS64 </MessageText></Message></Messages>

While running any report getting following error on screen

CCL-SRV-0501 The BIBusTKServer process caught an unexpected exception.

Cause

Missing files / Corrupt install.

Environment

Unix

Diagnosing The Problem

1. Ensure LD_LIBRARY_PATH (RHEL/Linux/Solaris) / LIBPATH (AIX) is correctly set according to the Operating System.
2. Ensure libRSRequest.so file is able to load all the linked library files and no error is encountered on executing this command “ldd libRSRequest.so” .
3. Check whether the file libRSRequest.so is present under <Cognos Installation Directory>/bin and <Cognos Installation Directory>/bin64 directories and permissions are correct for the user starting Cognos services. The libRSRequest.so file size is different in bin and bin64, so do not simply copy from either of the directory.

Resolving The Problem

If the libRSRequest.so file is found to be missing, then either

1. Copy it from the respective bin or bin64 directory from another working Cognos Analytics setup and restart Cognos services.

OR

2. Reinstall Cognos Analytics.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"11.0.9;11.0.8;11.0.7;11.0.6","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22012919