Troubleshooting
Problem
Saving in Cognos Configuration of IBM Cognos Framework Manager fails with the following error:
CAM-CRP-1132 An error occurred while attempting to request a certificate from the Certificate Authority service. The Certificate Authority service returned the following error: CAM-CRP-1040 Unable to calculate a hashing message authentication code (HMAC). Reason: java.lang.NullPointerException
Symptom
SSL with a 3rd party SSL certificate is enabled in the Cognos Analytics servers.
Client copied CAMKeystore file from the dispatcher to configuration/certs folder of FM.
Cause
Client forgot to configure usage of 3rd party CA in FM.
Resolving The Problem
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl6sAAC","label":"Install-\u003EConfigure"}],"ARM Case Number":"TS016146193","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"12.0.2"}]
Was this topic helpful?
Document Information
Modified date:
03 May 2024
UID
ibm17150192