IBM Support

Getting a blank section for Team Contents accessing Cognos Analytics 11.0.4 or higher with Cognos gateway in IIS

Troubleshooting


Problem

Getting a blank section when user click for Team Contents or My contents accessing Cognos Analytics 11.0.4 or higher with Cognos gateway in IIS

Symptom

Team content or My content appears a blank page

Cause

1. Customer configured Cognos Analytics with optional gateway in IIS but Mime types are not present

2. File extensions are disabled by default in server policy or cloud level as such all Mime types need to be explicitly enabled (undefined application) into request filtering

Environment

window

Diagnosing The Problem

Error message HTTP 1.1 404 Not Found for application/json, image/svg+xml or font/woff2

Resolving The Problem

1. Select ibmcognos (Application name alias) and double-click Mime Types.

Add the following Mime Types to your IIS configuration if they are not already present.



.svg : image/svg+xml
.woff : application/x-font-woff
.json : application/json
.woff2 : font/woff2
.template : text/html
. : text/plain


2. File extensions are disabled by default in Server Policy or Cloud level as such all Mime types need to be explicitly enabled (undefined application) into request filtering to allow "True"


If Team content is blank section and these Mine type are showed "HTTP 404 Error message" then please Allowed these file extension in Request Filtering

Example: .woff

.legacylaunchable

.welcomepage

.producVersion

.html


.gif
.css
.ttf
.json
.svg

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Administration and Configuration v11x","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22002076