IBM Support

The getCustomerList API does not return the customer.

Troubleshooting


Problem

Attempt to call getCustomerList API with customerid and OrganizationCode does not return the customer in the output.
 

Symptom

Enterprise configuration is as follows.
Org1 is primary enterprise. Customer is maintained by Org2.
When the getCustomerList API is called with customerid and OrganizationCode=Org1, it doesnot return the customer created under Org2.
 

Cause

The getCustomerList API input is incorrect.
 

Diagnosing The Problem

When customer is maintained by a different organization, then CallingOrganizationCode attribute should be used in the getCustomerList API
 

Resolving The Problem

To resolve, call the getCustomerList API with CallingOrganizationCode=Org1 instead of OrganizationCode=Org1.
This will return the customers created under org2.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
29 June 2018

UID

ibm10715897