Troubleshooting
Problem
The Get Event Message & Get Event Message For Webhook APIs are giving 'Maximum response size reached' error.
Symptom
Steps to simulate:
Call Get Event Messages for Event Code API
Request URL:
GET https://store.supply-chain.ibm.com/{tenantId}/v1/events/inventoryAdjustment/messages
Result: The error 'Maximum response size reached' appears
Cause
These APIs are supposed to return targeted event messages and not all the published messages till date.
Environment
IBM Sterling Store Inventory Management
Resolving The Problem
Passing startDate and endDate parameters solves the issue.
startDate- integer: The time after which you want to retrieve messages from. The format should be of long(milli secs)
endDate- integer: The time before which you want to retrieve messages from. The maximum is one day prior. (TTL = 86400). The format should be of long(milli secs).
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cxzVAAQ","label":"Call Center Store and SIM"}],"ARM Case Number":"TS013172492","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
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Document Information
Modified date:
24 November 2023
UID
ibm17022453