IBM Support

Gateway logs shows recurring error - A problem occurred when sending some HTTP/2 frames

Question & Answer


Question

Why is the gateway logs showing the following error in application domain used by API Connect ?
20240523T183203.234Z [apiconnect][0x80e00820][mpgw][error] source-https(apiconnect_https_9443): tid(35648704)[1.2.3.4]: A problem occurred when sending some HTTP/2 frames. Error code: -902.

Cause

These errors are generated from the libraries we use to handle the http2 connections and agree they are cryptic.
The code -902 means a callback error.

Answer

We are looking into translating these errors into something more useful for DataPower admins for which we have an internal issue created.
We have noticed these are sometimes generated when the browser closes out the connection in the middle of a transaction in the datapower WebGui.  We can not control how or when the browser closes the connection which means these errors will be sporadic. 
You can safely ignore them. 

[{"Type":"MASTER","Line of Business":{"code":"LOB67","label":"IT Automation \u0026 App Modernization"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSMNED","label":"IBM API Connect"},"ARM Category":[{"code":"a8m0z0000001it3AAA","label":"API Connect-\u003EManagement and Monitoring (MM)-\u003EGateway Service"}],"ARM Case Number":"TS016560734","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;and future releases"}]

Document Information

Modified date:
27 June 2024

UID

ibm17158983