IBM Support

Full Netcool/Impact FP28 Install, with NOI extensions, does not perform NOI ImpactDB Derby database changes.

Troubleshooting


Problem

The Impact Full install, with NOI extensions, is supposed to create, and populate, three schemas (NOI, Seasonality, and RelatedEvents) in the ImpactDB Derby database. However, in 7.1.0-TIV-NCI-FP0028, these database updates are no longer happening, on Full Install. The Full Install still reports that it completes OK.
Other ImpactDB derby schemas are not affected. For example, MWM tables are not affected. 
FP28 Upgrades are not affected.

Symptom

The Event Analytics Configure wizard, in DASH, reports the following error "com.micromuse.response.common.RespException: Could not discover schema for table NOI.DEFAULTVALUES at {jdbc:derby://hostname:1527/ImpactDB, jdbc:derby://hostname:1527/ImpactDB}"

Cause

The cause is related to Java uplift introduced in FP28.

Diagnosing The Problem

To diagnose the issue, connect to the ImpactDB Derby database. See instructions.
Once connected, run "show schemas" command as below:
 show schemas;
TABLE_SCHEM
------------------------------
APP
IMPACT
NULLID
SQLJ
SYS
SYSCAT
SYSCS_DIAG
SYSCS_UTIL
SYSFUN
SYSIBM
SYSPROC
SYSSTAT

12 rows selected
Notice that the NOI, RelatedEvents, and Seasonality schemas are missing.

Resolving The Problem

The issue is resolved in FP29, and planned for release in Q1 2023.
In the interim, for Full Netcool/Impact installs, with NOI extensions, there are 2 ways to fix the problem.
First, if there is no non-NOI data in the ImpactDB derby database, which needs to be preserved, that is, no MWM windows, for example, then the database files can be replaced with those included in the attachment. See steps for solution 1
Alternatively, if there is some non-NOI data in the ImpactDB derby database which needs to be preserved, then a scripted solution is provided. See steps for solution 2
Regardless of which solution is used, the final test is to confirm that the NOI.DEFAULTVALUES database has been created and populated and that the Event Analytics Configure page in DASH opens without error. To verify NOI.DEFAULTVALUES, connect to the database, using the steps here and issue this SQL command:

select * from NOI.DEFAULTVALUES;

Solution 1 - These steps replace the entire contents of the ImpactDB database.
  1. Shutdown the cluster (all Impact servers in the cluster). Then, the following steps can be done on the primary Impact server only and the replication will apply the updated DB to the secondary server.
  2. Delete the existing ImpactDB_NOI_FP28.zip file from the $IMPACT_HOME/install/dbcore/ directory.
  3. Save the file, repairedImpactDB_NOI_FP28.zip, included in the attachment, to $IMPACT_HOME/install/dbcore/
  4. Go to directory of the existing DB is $IMPACT_HOME/db/<ServerName>/derby. Backup the ImpactDB directory.
  5. Copy repairedImpactDB_NOI_FP28.zip from Step 3 into $IMPACT_HOME/db/<ServerName>/derby.
  6. Extract the file, and make sure original DB directory structure is the same as before.
  7. Start the cluster members (one by one).
Solution 2 - These steps create the NOI, RelatedEvents, and Seasonality schemas in an existing ImpactDB database.
Note: for these steps, at least the Primary Impact backend server should be up and running. 
  1. Delete all *sql.out files from the $IMPACT_HOME/logs/install directory
  2. Save the file, configure_impact_extensions_repairFP28.xml, from the attachment to /tmp
  3. Run the following command to repair the database:
cd /tmp
$IMPACT_HOME/bin/nc_ant -f /tmp/configure_impact_extensions_repairFP28.xml  > /tmp/configure_impact_extensions_repairFP28_run.out 2>&1
The output from the command is saved to the file configure_impact_extensions_repairFP28_run.out. The file is only for preserving the output of the script.  Once the script completes, examine the $IMPACT_HOME/logs/install/*sql.out files, and confirm that none of them received the "ERROR 08004: Connection authentication failure occurred" message. The following grep command can be used for this purpose: 

        grep -l -r "Connection authentication failure occurred" $IMPACT_HOME/logs/install/*

If further assistance is required, contact support via a Salesforce case.

Document Location

Worldwide

RepairPackageForFP28NOIDatabase.zip contains an ImpactDB .zip file for solution 1 and an XML Ant script for solution 2.

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Document Information

Modified date:
24 January 2023

UID

ibm16855347