Troubleshooting
Problem
When opening Framework Manager, there's a blank page open instead of the Cognos log in page.
Symptom
- blank page open in lieu of Cognos log in page.
- error message:
Content within this application coming from the website listed below is being blocked by Internet Explorer Enhanced Security Configurationabout:security_BMT11.exe
Cause
IE (<11.1.7FP5) and FM's HTML API renderer (>11.1.7FP5) doesn't trust the website it's attempting to connect to. FM will use the GatewayURI endpoint to connect. This endpoint needs to be trusted.
Normally the error will indicate which website it failed to trust. If you're getting the "about:security_BMT11.exe" this indicates there's some other application level trust issues being identified.
It had been identified that FM was pointing to a SSL enabled web server yet FM was still using a HTTP endpoint because the webserver had rules to handle the route from HTTP to HTTPS.
Diagnosing The Problem
Try to isolate by changing FM's gatewayURI from a webserver to the dispatcher.
Conversely, if the issue is on the webserver only, try to isolate further by simplifying the webserver, i.e. remove HTTPS to HTTP and remove SSO (disable windows authentication).
Conversely, if the issue is on the webserver only, try to isolate further by simplifying the webserver, i.e. remove HTTPS to HTTP and remove SSO (disable windows authentication).
Resolving The Problem
Due to the unique setup for this issue where there were special rules in webserver to handle HTTP to HTTPS, this caused issues with IE's trust and both HTTP and HTTPS URIs had to be added to the "Trusted Sites" list.
More information available here:
Related Information
Document Location
Worldwide
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Document Information
Modified date:
10 August 2022
UID
ibm16611395