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Framework Manager Cognos Analytics Single Sign on (SSO) Gateway URI

Troubleshooting


Problem

When using Single Sign On (SSO) with Cognos Analytics using the default gateway URI, users are prompted to login in Framework Manager.

Symptom

Users are prompted to login when using Framework Manager even though SSO is enabled.

Cause

Incorrect gateway URI in Framework Manger configuration.

Environment

Cognos 11

Resolving The Problem

Change the gateway URI in framework manager to

11.0.0 - 11.0.3 Gateway URI - http://<webserver>:<webServerport>/<alias>/cgi-bin/cognosisapi.dll

Dispatcher URI - http://<dispatcherServer>:<dispatcherPort>/p2pd/servlet/dispatch

11.0.4 - Gateway URI - http://<webserver>:<webserverPort>/<alias>/bi/v1/disp

Dispatcher URI - http://<dispatcherServer>:<dispatcherPort>/bi/v1/disp

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Framework and Map Manager v11x","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF025","label":"Platform Independent"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21988699