Troubleshooting
Problem
You receive errors when running custom API scripts/plugins or when using specific tools within Rhapsody. E.g. Harmony, AUTOSAR, etc...
Symptom
Examples of error messages:
"Can't query IRPApplication"
"Unable to connect to the Application"
or the tool may not respond when invoked.
Cause
Many tools within Rhapsody use the Rhapsody COM API. Usually this error means it is not registered.
Sometimes this can result from a faulty install or if multiple versions of Rhaposdy have been installed.
Resolving The Problem
1) Close Rhapsody
2) Open a cmd prompt as administrator
3) change to the Rhapsody installation directory. E.g. C:\Program Files (x86)\IBM\Rational\Rhapsody\8.4
4) Run the command:
regsvr32 RhapsodyServer.dll
5) You should receive a success message
6) Run the command:
Rhapsody.exe /RegServer
7) No message will appear for the last command.
8) Restart Rhapsody.
Document Location
Worldwide
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Product Synonym
Rational Rhapsody
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Document Information
Modified date:
27 May 2022
UID
ibm11125141