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Fixing corrupt records on the PERSONANCESTOR table in Maximo Application Suite (MAS)

Question & Answer


Question

How to fix corrupt records on the PERSONANCESTOR table in Maximo Application Suite (MAS), for example, with a Supervisor?

Cause

Duplicate or old records can cause the behavior

Answer

Steps and Script to run when you experience issues around person records (in this case with a Supervisor) :

  1. Create a backup copy of PERSONANCESTOR table 
  2. Delete all records from PERSONANCESTOR table.
  3. Run the following command on the maxinst pod from the terminal window to execute the attached script class V7501_37.class
  4. Navigate on the maxinst pod terminal: IBM\SMP\maximo\tools\maximo\internal
  5. Execute The command ./runscriptfile -fV7501_37

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m50000000CbPGAA0","label":"General"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
01 July 2024

UID

ibm17159316