IBM Support

Fields on People application are read-only in Manage 8.7

Troubleshooting


Problem

Users are not able to create Person records on People  applications since the fields are read-only
The issue starts happening after the upgrade to Manage 8.7

Cause

This is a known issue in Manage 8.7 reported in Defect DT257363.
The fix for this Defect is under development and will be released in a future Manage 9 pack.

Resolving The Problem

There is a reasonable simple workaround until the Patch is available. 
This consists on creating a Automation Script on the PERSON object Init() method.
Add the lines below:
from psdi.mbo import MboConstants

mbo.setFieldFlag("FIRSTNAME", MboConstants.READONLY, False)
mbo.setFieldFlag("LASTNAME", MboConstants.READONLY, False)
mbo.setFieldFlag("ADDRESSLINE1", MboConstants.READONLY, False)
mbo.setFieldFlag("CITY", MboConstants.READONLY, False)
mbo.setFieldFlag("POSTALCODE", MboConstants.READONLY, False)
mbo.setFieldFlag("COUNTRY", MboConstants.READONLY, False)

mbo.setFlag( MboConstants.READONLY, False)
This script will be executed every time a Person Record is initiated in the UI.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSRHPA","label":"IBM Maximo Application Suite"},"ARM Category":[{"code":"a8m50000000CbUVAA0","label":"System Administration-\u003EPeople"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.11.0"}]

Document Information

Modified date:
21 March 2024

UID

ibm17144976