Question & Answer
Question
Why are incorrect ASCII characters shown on the UI when few German characters are passed through API using API tester?
Sample scenario- Create a item with German characters for item description (using ManageItem API), it is saved with some ASCII characters in Database and the incorrect characters are displayed in Web Call Center.
Cause
Issue occurs when incorrect character code set on the browser
Answer
You need to set the text encoding/character encoding on the browser to UTF-8.
To set encoding to UTF-8, please refer to the corresponding browser documentation.
In addition to this, you should also set the character encoding in the input to the API through API tester
Sample Input to ManageItem API:
<?xml version="1.0" encoding="UTF-8"?>
<ItemList>
<Item Action="Manage" ItemID="100139" UnitOfMeasure="EACH" OrganizationCode="DEFAULT">
<PrimaryInformation AssumeInfiniteInventory="" ColorCode="" Description='Auswärtstrikot' EffectiveEndDate=""
ExtendedDescription='Auswärtstrikot' ExtendedDisplayDescription='Auswärtstrikot' ImageID="" ImageLabel=""
ShortDescription='Auswärtstrikot' />
</Item>
</ItemList>
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS6PEW","label":"Sterling Order Management"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Product Synonym
Sterling OMS
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Document Information
Modified date:
26 April 2019
UID
ibm10882080