IBM Support

"Failed to register ExcelLink Addin ... Add method of AddIns class failed" error when using Excel link

Troubleshooting


Problem

User tries to launch the Controller Excel link. User receives error.

Symptom


Failed to register ExcelLink Addin
Add method of AddIns class failed

Cause

There are other possible causes for similar errors.
  • TIP: See separate IBM Technote #1284004 for more examples.
 
This Technote specifically relates to the scenario where the cause is that the client device has incompatible version of Microsoft Office installed.

Example:
In one real-life customer case, the client device had 64-bit Excel installed.
  • Controller 10.2.1 is only compatible with 32-bit versions of MS Office.

Environment

Cognos Controller 10.2.1 with 64-bit MS Office.

Resolving The Problem

Uninstall MS-Excel 64-bit from the client device. Afterwards, install 32-bit version of Microsoft Office.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
27 January 2020

UID

swg21989085