Troubleshooting
Problem
Administrator launches 'Cognos Configuration'. Administrator clicks the green 'play' button, to start the Cognos 8 service. Administrator receives error message.
Symptom
Cognos Configuration
Cognos Configuration is performing the following tasks:
<tick> Stopping the service 'Cognos 8'
<tick> Generating cryptographic information
! Launching a JVM using 'Maximum memory in MB'
X Checking test results
Checking upgrade status
Starting the service 'Cognos 8'.
[Close] [Details]
[Launching a JVM using 'Maximum memory in MB']
1. [ERROR ] Failed to launch a test JVM with the current memory setting.
Details from the JVM :
Could not create the Java virtual machine.
[Checking test results]
1. [ERROR ] Start/restart was aborted.
Cause
The server has run out of Windows contiguous memory.
There are many different potential causes for this to have happened. For example:
- Scenario #1 - Third-party (non-IBM) software (such as Microsoft SQL or Citrix) which is also running on the same server, has taken memory resources away from Cognos software.
- Scenario #2 - Physical host (the server itself which is running Cognos 8) is underspecified / underpowered
- Scenario #3 - Third-party (Microsoft) bug affecting their Windows memory allocation process
- Scenario #4 - Aggressive/ambitious/unsuitable memory setting chosen for Cognos 8 BI service.
Environment
Problem could potentially effect any Windows server, but it is more likely to affect one which has been assigned multiple tasks/roles. For example, in addition to running the Cognos 8 service, it may also be acting as a SQL database server and/or Citrix server etc.
Resolving The Problem
Short-term workaround:
Reboot server. Immediately after the reboot, logon to the server and re-try. If the problem persists, try stopping other third-party services (for example Microsoft SQL) and then re-trying.
Long-term fix:
Depending on the environment, one of the following may be most suitable:
- Scenario #1 - Move third-party (non-IBM) software (such as Microsoft SQL or Citrix) to other servers, to leave Cognos 8 service dedicated on this original server.
- Scenario #2 - Increase the physical memory in the server hardware, and check Windows virtual memory settings
- Scenario #3 - Contact your third-party supplier (for example Microsoft) for advice, and to check for bugs in their contiguous memory allocation.
- For example, see the following websites for examples of Microsoft bugs that relate to this problem:
- Scenario #4 - Consider reducing the size of your 'Maximum memory in MB'.
Related Information
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Document Information
Modified date:
28 November 2022
UID
swg21386665