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Event Analytics (on-prem) Pattern not visible in GUI

Troubleshooting


Problem

After moving a Pattern to a different state, for example: [Active] -> [Archived], it is possible for Groups to get out of step with one or more Patterns, after this the Pattern disappears from the NOI GUI and can no longer be used.

Symptom

The Pattern disappears from the NOI GUI and can no longer be used. If the state of a Pattern is different from the state of its allocated groups, then it does not appear in the UI.

Cause

The Groups configuration gets out of step with the Pattern configuration in the ImpactDB. For Patterns to appear in the UI, its state must match that of its allocated groups.

Environment

On premises NOI installation.

Diagnosing The Problem

Run the following SQL on the derby ImpactDB, to determine whether any Patterns exist where the Groups are out of step:

select g.GROUPNAME, g.TYPE as "GROUP TYPE", g.PATTERN, p.ACTION from RELATEDEVENTS.RE_GROUPS g, RELATEDEVENTS.PG_PATTERNS p where g.PATTERN = p.GENERALIZED_PATTERN and g.PATTERN is not NULL and g.TYPE != p.ACTION;
 
If the SQL returns nothing, all is good. 
For information on how to connect to the derby ImpactDB, see here.

Resolving The Problem

If records are found, then for each Pattern found run the following SQL (replace <patternname> in the SQL shown for each Pattern, in turn):

select count(*) from RELATEDEVENTS.RE_GROUPEVENTS WHERE GROUPNAME in (SELECT GROUPNAME from RELATEDEVENTS.RE_GROUPS where PATTERN = '<patternname>' and TYPE != 'NEW');
 
select count(*) from RELATEDEVENTS.RE_GROUPS      WHERE PATTERN = '<patternname>' and (TYPE != 'NEW' or PATTERNACTION != 'NEW') ;
 
select count(*) from RELATEDEVENTS.PG_PATTERNS    WHERE GENERALIZED_PATTERN = '<patternname>' and ACTION != 'NEW';
If the output shows rows affected, run the following SQL to move the pattern and all its groups to [New] (once again, replace <patternname> in the SQL shown for each one, in turn):

update RELATEDEVENTS.RE_GROUPEVENTS set TYPE = 'NEW' WHERE GROUPNAME in ( SELECT GROUPNAME from RELATEDEVENTS.RE_GROUPS where PATTERN =  '<patternname>' and TYPE != 'NEW');

update RELATEDEVENTS.RE_GROUPS set TYPE = 'NEW' , PATTERNACTION = 'NEW' WHERE PATTERN = '<patternname>' and (TYPE != 'NEW' or PATTERNACTION != 'NEW') ;

update RELATEDEVENTS.PG_PATTERNS  set ACTION = 'NEW' WHERE GENERALIZED_PATTERN = '<patternname>' and ACTION != 'NEW';
You should then, once again, be able to see the Pattern in the GUI.
 

Document Location

Worldwide

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Document Information

Modified date:
27 November 2023

UID

ibm17082698