Troubleshooting
Problem
After an over-the-top upgrade of Cognos analytics from 11.1.t to 11.2.4, Cognos Analytics application gives an error, 'AAA-SYS-0001 An Internal error occurred', in the login screen.
Saving or trying to export the configuration in IBM Cognos configuration, gives the following error:
[ ERROR ] CAM-CRP-1054 No configuration was loaded.
Cause
Expired Cognos cryptographic keys and/or symmetric keys.
Diagnosing The Problem
Review of the 'Date modified' of files in the <Install>/configuration/certs and <Install>/configuration/csk folders, will show a date older than the value of “Certificate Lifetime in Days” found under Local configuration > Security > Cryptography in the IBM Cognos Configuration utility.
Resolving The Problem
1) Open the IBM Cognos configuration.
2) In the left side 'Explorer' section, select Cognos under Local configuration > Security > Cryptography
3) Change the “Certificate Lifetime in Days”. For example, if the existing value is 729, increase it to 730.
4) Save the IBM Cognos Configuration. It should save successfully this time.
5) If the Save is successful, revert the change made in step#3 and save again.
6) Restart Cognos Service.
Note:
If the IBM Cognos Configuration could not be saved, even after changing the Certificate Lifetime, then re-do the configuration following the steps in the following tech-note:
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"ARM Category":[{"code":"a8m50000000Cl3zAAC","label":"Administration"}],"ARM Case Number":"TS016101332","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"11.2.4"}]
Was this topic helpful?
Document Information
Modified date:
07 August 2024
UID
ibm17162163