IBM Support

Error when restoring archive file in Guardium. Exit value =255

Troubleshooting


Problem

When restoring an archive file in Guardium you see the error in the GUI->Guardium Monitor->Aggregation/Archive Log. For example: 735888-hostname-w20141019.030229-d2014-10-17.dbdump.enc from 9.1.1.1: Exit value = 255

Cause

Guardium can not reach the archive server to get the archive file because one or more parameters in its catalog entry are incorrect.

Resolving The Problem

1. Navigate to GUI->Administration Console->Data Management-> Catalog Archive

2. Use the search function to find the archive file you are trying to restore. Note you can leave hostname field blank and it will search all hostnames.

3. Verify that the details (Hostname, Path, User Name and Password) are correct by double checking on the archive server directly.

4. Verify that the user have write/execute permissions for the directory specified in the Directory box.

5. Set the details correctly and try the restore again.

If you are still getting an error when restoring the archive please go through the following:

i) In CLI run:

support must_gather app_issues

You will be prompted for a time to run the debugger for.

ii) Set the debugger for a number of minutes and try to restore the archive again in that time.

iii) Open a ticket to IBM support and attach the file created in the step above.

[{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Guardium Database Activity Monitor","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"9.1;9.0;8.2;9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21688171