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Error 'Server was unable to process request ---> System.OverflowException' when publishing Data Mart

Troubleshooting


Problem

User attempts to publish to Data Mart, by performing the following: * User clicks on 'Transfer - Publish Data and Structures - Publish Data Mart' * User selects relevant Data Mart template (e.g. called 'TST1'), and selects the values * User clicks on the start publish icon After doing the above, the user receives error message in the Log Report (on screen).

Symptom

Scenario#1

Log Report:
TST1: System.Web.Service.Protocols.SoapException: Server was unable to process request. ---> System.OverflowException: Overflow at FrDMPublishT.DMPublishTClass.PublishTemplate(String&, sGUID,String& sUser, String& sTemplateID, Int32& IdimBits, String& sPeriods, Int32& IErrNumber, STring& sErrDescription)
at Cognos.Controller.Proxy.CCRWS.DMPublishT_PublishTemplate(StringsGUID, String sUser, String STemplateIS, Int32 IDimBits, String sPeriods, Int32& IErrNumber, String& sErrDescription)
--- End of inner exception stack trace ---

Scenario#2

Log Report:
TST1: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.OverflowException: Overflow
at FrDMPublishT.DMPublishTClass.PublishTemplate(String& sGUID, String& sUser, String& sTemplateID, Int32& lDimBits, String& sPeriods, Int32& lErrNumber, String& sErrDescription)
at Cognos.Controller.Proxy.CCRWS.DMPublishT_PublishTemplate(String sGUID, String sUser, String sTemplateID, Int32 lDimBits, String sPeriods, Int32& lErrNumber, String& sErrDescription)

Event Log (Application log) on server:
Event Type: Warning
Event Source: Cognos Controller
Event Category: None
Event ID: 0
Date: 24/09/2008
Time: 08:07:33
User: N/A
Computer: SERVERNAME
Description:
Error occured at 24/09/2008 08:07:33 in Cognos Controller, Error No=5, Source=ControllerProxyClient, Description=System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.OverflowException: Overflow
at FrDMPublishT.DMPublishTClass.PublishTemplate(String& sGUID, String& sUser, String& sTemplateID, Int32& lDimBits, String& sPeriods, Int32& lErrNumber, String& sErrDescription)
at Cognos.Controller.Proxy.CCRWS.DMPublishT_PublishTemplate(String sGUID, String sUser, String sTemplateID, Int32 lDimBits, String sPeriods, Int32& lErrNumber, String& sErrDescription)
--- End of inner exception stack trace ---, HelpFile= HelpContext=0

Cause

There are several different potential causes of similar error messages:

  • Scenario #1 - Controller DataMart database is out of space
  • Scenario #2 - Code production issue (reference #593168) in Controller 8.3 sp2 (8.3.1028 inside 'Help - About') or earlier.
    • This is triggered only if the template has 'Include Intercompany Details' ticked.

Diagnosing The Problem

If the problem only occurs if the template has 'Include Intercompany Details' ticked, then it is likely to be scenario #2.

Resolving The Problem

Scenario #1 - Controller DataMart database is out of space
Ensure that the Controller Data Mart database is not full, and can grow.

TIP:

  • There are 3 different types of data mart 'targets', which means that you should check the relevant database for your target
  • See attachment 'KB1036477 - visual description of different types of Data Mart targets.pdf' for a visual description of these targets.

Steps:
NOTE: The following instructions assume you are using SQL 2000. Modify the instructions appropriately for SQL 2005 or Oracle.

Scenario #A - Data Mart target is 'none' (RDBMS):
  1. Logon to the Controller application server
  2. Launch Cognos Controller Configuration from the Start Menu
  3. Open the section 'Database connections' and locate the relevant database
  4. Make a note of the SQL server name and database name that relates to this Controller database
  5. Logon to the relevant SQL server
  6. Launch SQL Enterprise Manager
  7. Expand the section 'databases' and locate the relevant database
  8. Right-click on the database and choose 'properties'
  9. Click on the tab 'data files'
  10. Ensure that 'automatically grow file' is ticked. TIP: typically ensure that 'By percent' is selected, with a value of '10'
  11. Ensure that 'unrestricted file growth' is ticked
  12. Ensure that the hard drive that is referred to inside 'file location' (e.g. D:) is not full
  13. Click on the tab 'transaction log'
  14. Repeat steps 10, 11, 12 and 13 (i.e. for the transaction log)

Scenario #B - Data Mart target is 'MS SSAS' (OLAP / MSAS):

Part One - Locate the MSAS repository
  1. Logon to the relevant Microsoft Analysis Server (MSAS)
  2. Launch Analysis Manager from the start menu
  3. Expand 'Analysis Servers'
  4. Right-click on <servername> and choose 'Edit Repository Connection String'
  5. Make a note of the value inside the section 'local'

TIP: By default, this will be: 'Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\Program Files\Microsoft Analysis Services\Bin\msmdrep.mdb'. However, for increased scalability, your MSAS repository should have been migrated to a SQL database. In this case, the entry will point to a SQL database.

Part Two - Ensure the MSAS repository is not full
If the repository is a file (e.g. C:\Program Files\Microsoft Analysis Services\Bin\msmdrep.mdb) then
  • Ensure that this file is not full, or located on a hard drive that is full
  • Consider migrating the repository to a SQL database

If the repository is a SQL database, ensure that
  • This database is not full
  • In other words, perform the same steps outlined in 'Scenario #1', but looking at the MSAS repository SQL database

Scenario #C - Data Mart target is 'Cognos BI' (separate/dedicated SQL or Oracle database):
  1. Logon to the Controller application server
  2. Launch Cognos Controller Configuration from the Start Menu
  3. Open the section 'Database Connections for publish to datamart' and select the relevant database
  4. Make a note of the SQL server name and database name that relates to this Controller database
  5. Logon to the relevant SQL server
  6. Launch SQL Enterprise Manager
  7. Expand the section 'databases' and locate the relevant database
  8. Right-click on the database and choose 'properties'
  9. Click on the tab 'data files'
  10. Ensure that 'automatically grow file' is ticked. TIP: typically ensure that 'By percent' is selected, with a value of '10'
  11. Ensure that 'unrestricted file growth' is ticked
  12. Ensure that the hard drive that is referred to inside 'file location' (e.g. D:) is not full
  13. Click on the tab 'transaction log'
  14. Repeat steps 10, 11, 12 and 13 (i.e. for the transaction log)

Scenario #2 - Code production issue #593168.

Fix:
Upgrade to Controller 8.3 sp3 (also known as v8.3.1029 inside 'help - about') or later.

Workaround:
Modify Data Mart template (e.g. TST1) so that box 'Include Intercompany Details' is unticked.

KB1036477 - visual description of different types of Data Mart targets.pdf

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.4;8.3","Edition":"Edition Independent","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1036477

Document Information

Modified date:
15 June 2018

UID

swg21347418