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Error "permission denied: Your account does not have the group memberships required to access the requested resource" when accessing Enterprise Test Management (ETM) artifact links in CSV/PDF exports

Troubleshooting


Problem

A user receives "permission denied: Your account does not have the group memberships required to access the requested resource" accessing Enterprise Test Management (ETM artifact links, such as test case links) in CSV/PDF exports. The same user can browse those artifacts in an ETM project area. 

Symptom

A user receives error accessing Enterprise Test Management (ETM) accessing artifact links, such as test case links, in CSV/PDF exports.
permission denied: Your account does not have the group memberships required to access the requested resource
The same user can browse those artifacts in an ETM project area. 

Cause

The user is either missing the XML Export permission in the project areas or has a Contributor license 

Environment

All supported ETM versions

Resolving The Problem

Resolving Permissions:
  1. Go to Manage this Project Area for the project areas with test artifacts linked the PDF/CSV file
  2. Go to Permissions > click "Show by Operation" and search for "XML"
  3. Add XML Export to a role assigned to the user accessing test artifact links
Resolving Licensing:
  1. From JTS Administration, open the user and provide the Quality Professional license. The Contributor license is not sufficient for this operation

Document Location

Worldwide

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Product Synonym

Rational Quality Manager

Document Information

Modified date:
22 January 2020

UID

ibm11275292