IBM Support

ERROR: No Java virtual machine was found, when starting ClearQuest RCP client

Troubleshooting


Problem

This technote explains why the error, "No Java virtual machine was found", occurs when starting the IBM® Rational® ClearQuest® Eclipse rich client platform (RCP).

Symptom

The following error can occur when attempting to start the RCP client:


A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run ClearQuest. No Java virtual machine was found after searching the following locations: -Xj9

Cause

The IBM JRE packaged with the Rational products, including ClearQuest, is either missing or corrupt.

Diagnosing The Problem

Users can verify if the JRE files are missing by checking for files in the following directory, assuming a default installation path:

<drive>:\Program Files\Rational\Common\java

Resolving The Problem

ClearQuest can only operate with the packaged IBM JRE. It does not support separately downloaded JRE installations. In the event that the IBM JRE is missing or corrupted, perform a repair or reinstallation of ClearQuest on the affected computer. Disable the anti-virus and other file-level security software programs during either process.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Client - Eclipse RCP","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.1;7.0.1.1;7.0.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21259491