IBM Support

Error in Mobile when new work order is sync which had an Inspection record

Troubleshooting


Problem

There are times when the sync of the mobile device would bring a new Work Order, however on accessing that record there will be an error if it had an Inspection record associated with it.

Symptom

Error on screen
This record is not on your device. Try again or wait until you are online.

Cause

The sync to bring work orders is doing precisely that, brings only work orders.  However the Inspection record is not in sync as that was not brought into the mobile database.  There is a performance balance to be had here, if all Inspections records also sync this would be detrimental, however if an organization often has Inspections associated to Work Orders then there is a need to have it.

Environment

Maximo Integration Framework 8.7.0
IBM Maximo Mobile 8.11.0
Maximo Application Framework 8.11.0
Maximo Manage 8.7.4

Diagnosing The Problem

Mobile :
1)Create workorder in Mobile with inspection form
2)Update the Section A from Inspection form

Desktop:
1)Open the same workorder .
2)Update Section B,C from Inspection form

Mobile:
1)Refresh the workorder.
2)Check the Inspection form (B,C sections not updated on Inspection form)

RESULT: The initialized inspection in the first download only, this is by design

EXPECTED RESULT: The desireable effect is to sync the inspection every time

Resolving The Problem

The recommendation could be to modify the code to ensure a full sync occurs when a work order record is retrieved.
This could be achieved as follows:
Customize the File to be changed:  ExecutionFormDataController.js to force a full data sync
Action:  Remove items.length check
ExecutioFormDataController.js sample code

Document Location

Worldwide

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Document Information

Modified date:
01 May 2024

UID

ibm17149958