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Error message "SESN0008E: A user authenticated as anonymous..." in log file when running reports

Troubleshooting


Problem

Attempts to run any report using maximo result in the error [ERROR] [MAXSERVER] [] Error in getHttpSessionAttribute method java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor126.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke (DelegatingMethodAccessorImpl.java:55) at java.lang.reflect.Method.invoke(Method.java:613) at com.ibm.tivoli.maximo.report.script.MXReportScriptContext. getHttpSessionAttribute(MXReportScriptContext.java:628) at com.ibm.tivoli.maximo.report.script.MXReportScriptContext. isReportJobCancelled(MXReportScriptContext.java:1294) at com.ibm.tivoli.maximo.report.script. MXReportJobCancelManager$MXReportJobCancelThread.run (MXReportJobCancelManager.java:121) Caused by: com.ibm.websphere.servlet.session. UnauthorizedSessionRequestException: SESN0008E: A user authenticated as anonymous has attempted to access a session owned by user:MAXuser. internal.local:###/CN=CN\, OU=Users, DC=DC,DC=internal,DC=local.

Symptom

The error does not seem to cause reports to not execute

Cause

Websphere Session Security is causing this error to be thrown

Diagnosing The Problem

If you see the above error, proceed to try the solution below

Resolving The Problem

The SESN0008E error can be corrected by disabling session security
integration in the WAS admin console:

Servers > Server types > WebSphere application servers > server_name >
Session management

Disable the "Security integration" option.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"BIRT","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6;7.6.0.5;7.6.0.6;7.6.0.7;7.6.0.8;7.6.0.9","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
17 June 2018

UID

swg21995035