Troubleshooting
Problem
User clicks 'Transfer - External Data - Import from Flat Files'. User selects import specification, import file (e.g. TXT file or CSV file) and clicks 'Run' button. After the import has finished, user receives the 'Statistics - Import of External Data' window. User highlights the import, and chooses 'preview' to see the import log. User receives error #1. User then clicks 'Transfer - Log Reports' then clicks 'External Data' tab. User highlights the most recent import (the one with the problem), and clicks 'preview'. User receives error #2.
Symptom
Error #1
Information
Standard Error
Source: C1.C1Preview.2
Description: Index was outside the bounds of the array.
OK
Error #2
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Cause
There were too many errors (during the import) to view successfully.
TIP: Click 'Transfer - Log Reports' then click 'External Data' tab. Highlight the most recent import (the one with the problem) and look under the column 'Discarded Transactions'. You will see a huge number (for example 20000) rather than a more sensible number (for example 3 or 4).
Typically, the reason why there were such a huge number of discarded transactions was that something fundementally was wrong with the import, such as:
- The wrong import specification was chosen
- The import file (CSV/TXT) was corrupt
-
- For example, it was formatted incorrectly (e.g. as an XLS file not a CSV file etc.)
-
Resolving The Problem
Correct the fundemental problems in your import, and re-try. Steps:One method of troubleshooting is to:
- Open the CSV file (for example in Excel)
- Delete 95% of the rows (to make the file much smaller)
- Re-save the CSV file
- Import
This will create a much smaller failure report, so (by assuming that the problem with the remaining 5% of data is the same as for the other 95% of data) you can locate the source of the problem.
Historical Number
1041689
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Document Information
Modified date:
15 June 2018
UID
swg21367384