Troubleshooting
Problem
An IBM Engineering Lifecyle Management (ELM) solution 7.0 upgrade is aborted during the addTables process with the error:
2020-03-25 10:18:59,438 CRJAZ2523I Setting the global server rename state to false and the validation state to false.
2020-03-25 10:18:59,781 CRJAZ2105I Checking for a running server...
2020-03-25 10:19:02,031 CRJAZ3170E The operation cannot continue because a previous database operation is in progress: Add tables in progress.
Symptom
An IBM Engineering Lifecyle Management (ELM) solution 7.0 upgrade is aborted during the addTables process with the error:
2020-03-25 10:18:59,438 CRJAZ2523I Setting the global server rename state to false and the validation state to false.
2020-03-25 10:18:59,781 CRJAZ2105I Checking for a running server...
2020-03-25 10:19:02,031 CRJAZ3170E The operation cannot continue because a previous database operation is in progress: Add tables in progress.
Cause
It is possible that the 7.0 upgrade was started previously, the addTables process did not complete, and the upgrade was started again without restoring the product database.
Environment
Upgrading any IBM Engineering Lifecyle Management (ELM) product to version 7.0 (Engineering Requirements Management DOORS Next (ERM), Engineering Workflow Management (EWM), Engineering Test Management (ETM)
Diagnosing The Problem
Look for a previous addTables, for example, repotools-rm_addTables.log.bak to see if the addTables process was previously run and did not complete. If addTables completed, the log will state that the ADMIN user has logged out of the database and "Database tables were added successfully."
Resolving The Problem
In IBM Engineering Lifecyle Management (ELM) product version 7.0 , the repotools-xx addTables process will not run if a previous addTables process did not complete. The product (EWM, ETM, ERM) database must be restored and the upgrade run again to allow addTables to complete successfully. This behavior is new to the 7.0 release.
If the addTables process in the 7.0 upgrade failed and root cause is unknown, contact IBM support for assistance.
Document Location
Worldwide
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Document Information
Modified date:
28 April 2021
UID
ibm16117940