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"Error Contacting User Manager ... System.Exception: Security Error 1" when launching Controller, caused by firewall between Primary/Secondary servers

Troubleshooting


Problem

User launches Controller client. User chooses the database. User then authenticates with their username/password. An error appears.

Symptom


Error Contacting User Manager.

Details:
System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: Security Error 1
at Cognos.Controller.Proxy.SoapExtension.ServerExtension.ValidateNativeUser(SoapMessage& message)
at Cognos.Controller.Proxy.SoapExtension.ServerExtension.ProcessMessage(SoapMessage message)
at System.Web.Services.Protocols.SoapMessage.RunExtensions(SoapExtension[] extensions, Boolean throwOnException)
at System.Web.Services.Protocols.SoapServerProtocol.CreateServerInstance()
at System.Web.Services.Protocols.WebServiceHandler.Invoke()
at System.Web.Services.Protocols.WebServiceHandler.CoreProcessRequest()

Cause

There are many different causes of similar "Security Error 1 ... ValidateNativeUser" errors
  • TIP: For more examples, see separate IBM Technote #6204010.
  
This Technote specifically relates to the scenario where the cause is that there is a firewall (between primary & secondary servers) blocking communication from the 'secondary' server to the "IBM Cognos Controller User Manager" service (running on the 'primary' server).
  • This stops any users (who are trying to connect to the 'secondary' server) from being authenticated successfully by Controller.

Environment

Customer has two Controller application servers, running in a primary/secondary configuration (using the ccrRemoteServer parameter).

Resolving The Problem

Disable the firewall between the 'primary' and 'secondary' Controller application servers.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"ARM Category":[{"code":"a8m0z000000brYKAAY","label":"Installation"}],"ARM Case Number":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
22 July 2020

UID

swg22009919