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Error "Connection Refused" when starting IBM DOORS Web Access (DWA)

Troubleshooting


Problem

Error "Connection Refused" in Tomcat window when starting IBM DOORS Web Access processes.

Symptom

The Tomcat process for DOORS Web Access does not start successfully. The command window either disappears or displays "Connection Refused" error if you try to run server.start.bat file directly on the Command Prompt window.

Cause

The issue normally caused by the DOORS Web Access port numbers are not available through system's firewall.

Resolving The Problem

The firewall rules need to be updated or modified to allow DWA ports. The following list of default ports are assigned while configuring DWA. If you specified different port numbers, you may want to verify from server.xml file located in #DWAInstallation\server\config folder.

  • 8005
  • 8080
  • 8443
  • 8009

After setting up the firewall rule, you will need to restart DWA components (Broker, Derby, Interop and Server).

Document Location

Worldwide

[{"Type":"SW","Line of Business":{"code":"LOB59","label":"Sustainability Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSYQCV","label":"IBM Engineering Requirements Management DOORS Web Access"},"ARM Category":[{"code":"a8m50000000CiqdAAC","label":"DOORS->DOORS Web Access (DWA)"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
10 May 2021

UID

ibm16451267