IBM Support

Error connecting to database when testing connection in Cognos Connection: QE-DEF-0321

Troubleshooting


Problem

Error occurs when attempting to connect to SQL Server through OLE DB from Cognos Connection or Framework Manager.

Symptom


QE-DEF-0321 The userId or password is either missing or invalid.
QE-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database(s) in: testDataSourceConnection
UDA-SQL-0031 Unable to access the "testDataSourceConnection" database
UDA-SQL-0129 Invalid login information was detected by the underlying database
UDA-SQL-0167 The OLEDB driver returned the following values: SQL STATE = "42000", SQL ERROR CODE="18,456"
UDA-SQL-0165 The OLEDB driver returned the following message: "Login failed for user gosl'."
UDA-SQL-0166 The OLEDB source returned the following message: "Microsoft OLE DB Provider for SQL Server"
UDA-SQL-0206 The OLEDB driver returned the following value: HRESULT= DB_SEC_E_AUTH_FAILED 18456

Original Error: QE-DEF-0285 Logon failure.
QE-DEF-0321 The userId or password is either missing or invalid.
QE-DEF-0068 Unable to connect to at least one database during a multi-database attach to 1 database(s) in:
testDataSourceConnection
UDA-SQL-0031 Unable to access the "testDataSourceConnection" database.
UDA-SQL-0129 Invalid login information was detected by the underlying database.
UDA-SQL-0167 The OLEDB driver returned the following values: SQL STATE = "42000", SQL ERROR CODE = "4,060".
UDA-SQL-0165 The OLEDB driver returned the following message: "Cannot open database requested in login 'Inform'. Login fails.".
UDA-SQL-0166 The OLEDB source returned the following message: "Microsoft OLE DB Provider for SQL Server".
UDA-SQL-0206 The OLEDB driver returned the following value: HRESULT= E_FAIL 4060".

Cause

The password contains an invalid character.
For example, the password may contain the @ symbol.

Resolving The Problem

Change the password to a string of characters that does not use the @ or any other invalid characters.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Connection","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.2;10.2.1;10.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Framework Manager","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SSTQPQ","label":"IBM Cognos Series 7 PowerPlay"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"PowerPlay Enterprise Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21341770