IBM Support

Error AIUCO1005E When trying to save a user in MAS.

Troubleshooting


Problem

 In MAS, you can come across this error on create or save the user record.

Symptom

user

Cause

The reason you are seeing this error is due to the secondary email field on the user record. Some system administrators use the secondary email field as a back up and specify another users email address in this field.
In this example, user xxxxxxx email address is used in another user record, which is causing the error.

Diagnosing The Problem

If you do encounter this error, we suggested that you review the usersyncagent pod logs for any errors.

In this example, we find that there is a problem with the users email address -
(xxxxxx@anywhere.com is an example email address used for this document. The user you're trying to save in MAS shows in the logs).
ERROR [xxxxxxx@anywhere.com] Got exception: [main xxxxxx@anywhere.com] synched status_code: 400 r.text Error 400: BMXAA4211E -Database error number -803 occurred on email  E-mail=xxxxxxx@anywhere.com Report the error to the owner of the deployment.

Resolving The Problem

First, go to Manage > Security > Users > xxxxxx@anywhere.com, and expand the primary email field.

Expand the drop down to see whether there is a secondary email. If you find that there is, Delete the email and save the settings. Once done, check whether you are able to save the user.

If, no secondary is listed and you have database access to run a query you can run the following -

select  Personid FROM EMAIL where EMAILADDRESS ='xxxxxx@anywhere.com’;
select * from maxuser where personid='PERSONID' (take the Personid from the 1st query and put it in the second query to get the output).

The output shows what user that this email is being used as a secondary. You can them go back to the Manage > Security > Users > look at the primary email field for the user found from the select. Expand the field, the email address in question that is referenced in the logs.

**If you are a hosted customer and do not have database access you can submit a case with the support team so that we can have these select statements run for you**

Document Location

Worldwide

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Document Information

Modified date:
19 July 2023

UID

ibm17013167