Troubleshooting
Problem
Cannot set a person record to inactive as an error message indicates the person record is in a group, but it is not.
Symptom
Error: "BMXAA3084E – Failed to deactivate the person because he/she is assigned on a person group"
Cause
This is in an upgraded database where labor records have not been upgraded properly.
Resolving The Problem
STEPS:
1. Query the persongroupteam table for the person record that cannot change status:
select * from persongroupteam where respparty = 'LABESANS'
2. Run delete statement to remove the person from the person group
delete from persongroupteam where respparty = 'LABESANS'
Once the person record has been removed from the person group via the backend, the system should allow changing the person record to INACTIVE status.
Was this topic helpful?
Document Information
More support for:
IBM Maximo Asset Management
Software version:
7.1, 7.1.1, 7.1.2, 7.2, 7.2.1, 7.5
Document number:
151131
Modified date:
17 June 2018
UID
swg21469133