Troubleshooting
Problem
Error -951 returned by Dynamic Server (IDS) on Windows when using dbaccess.
Resolving The Problem
As user informix, you attempt to connect to IBM® Informix® server on a Windows platform using dbaccess, and receive the following error message:
- -951: Incorrect password or user informix is not known
on the database server
Same time you may receive following error message in the message log file:
- listener-thread: err = -951: oserr = -###: errstr = informix:
Incorrect password or user informix is not known on the database server.
CAUSE
The error -951 typically relates to the domain name server (DNS) or user authentication. The following situations can cause error -951:
- Informix user account was deleted and recreated
- Windows server membership has changed from domain to workgroup
- Windows server membership has changed from workgroup to domain
- Change in domain default policy for informix domain user
- User ‘informix’ is not a member of administrator group at the server
- Informix user password has expired
SOLUTION
The problem can generally be resolved by reinstalling Informix server product per the Installation Guide for IBM® Informix® Dynamic Server for your Windows platform. It may be necessary to remove the Informix registry entries and remove and recreate the user informix and group Informix-Admin.
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Document Information
Modified date:
16 June 2018
UID
swg21200068