IBM Support

Error: 502 Bad Gateway when accessing Schedules tab from Admin console.

Troubleshooting


Problem

When accessing the Cognos Portal’s Schedule tab from the Gateway, users get 502 Bad gateway error. If users access the Schedules tab directly from Dispatcher, it shows blank White screen and does not load the list of Schedules even after giving System Admin permission.

Symptom

502 Bad Gateway as shows in below screen capture when click Schedules tab from the Gateway or Black White page if we load the similar Schedules page from the Dispatcher Directly.

image-20220623103318-1

Cause

The Preferences set to 500 for the number of items to display.

Environment

Cognos 11.1.7, all version of Operating System.

Diagnosing The Problem

We can see below errors in Cog audit and Cog server logs which shows the request took long time to complete and timed out.

CM-SYS-5225 Content Manager has detected a long running request. The request took 431 seconds to finish

CM-SYS-5133 While processing your request, Content Manager waited for 601.061 seconds to access objects that are currently locked. Contact your IBM Cognos system administrator if this problem recurs.

Resolving The Problem

Update the Number of Entries in list view from My Preferences to 25-100 based on the environment and save the changes.

Document Location

Worldwide

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Document Information

Modified date:
23 June 2022

UID

ibm16597941